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                                     Chapter 12 – Lab/Student

12.2.4 Lab: Customize Settings in Windows XP
Introduction

Print and complete this lab.

This lab is comprised of five parts. This lab is designed to be completed in multiple lab sessions.

Part 1: Managing Virtual Memory, Startup Options, and Windows Update in Windows XP

In this part of the lab, you will customize Virtual Memory settings. You will customize the Startup Folder and RunOnce Key in the Registry. You will change the default Windows Update option.

Recommended Equipment

· A computer running Windows XP Professional

· Internet access

Step 1

Log on to Windows as an administrator.
Choose Start. Double-click My Computer. 

The My Computer window appears.

Step 2
Double click the D: drive.

The Disk is not formatted window appears. 

Click Yes.

Step 3
The Format Local Disk (D:) window appears.
Choose NTFS in the File system drop-down menu, and then click Start.

A warning window appears.

Click OK.
Windows formats the drive.

When the Format Complete window appears, Click OK.
The Format Local Disk (D:) window re-appears.  

Click Close.
Close all open windows.
Step 4
Choose Start. 
Right-click My Computer, and then click Properties.

The System Properties window appears.

Click the Advanced tab.
Click Settings in the Performance area.
Step 5
The Performance Options window appears.
Click the Advanced tab.

What is the current size of the Virtual Memory (paging file)?
Click Change in the Virtual Memory area.
The Virtual Memory window appears.

What Drive [Volume Label] contains the paging file?

Choose the D: drive.

Click the Custom size radio button.

Look at the recommended size in the Total paging file size for all drives section of the Virtual Memory window.
Type the recommended file size in the Initial size (MB) field.
Type the recommended file size again in the Maximum size (MB) field.

Click Set.
Choose the C: drive.

Click the No paging file radio button, and then click Set.

Click OK.
The System Control Panel Applet message window appears. 
Click OK.
Click OK.
Click OK.

The System Settings Change window appears.

Click Yes to restart your computer now.
Step 6
Log on to Windows as an administrator.

Open the Virtual Memory window.

What Drive [Volume Label] contains the paging file?

Click Cancel.
Click Cancel.
The Performance Options window closes.
Click Cancel.
Step 7
Choose Start > All Programs > Games > right-click FreeCell > Send To > Desktop (create shortcut).
Step 8
Click and drag the Freecell to the Start button. 
The Start menu appears.

Do not release the shortcut icon.

Drag the icon to All Programs.

The All Programs menu appears.

Drag the icon to Startup.

The Startup menu appears.

Drag the icon to the Startup menu.

Release the icon.
Step 9
Log off Windows.

Log on to Windows as an administrator.

What happens when you log in?

Close the Freecell application.

Step 10
Choose Start > Run.
Type regedit In the Open: field > OK.
CAUTION:
Incorrect changes to the registry can cause system errors and/or system instability.
The Registry Editor window appears.

Expand the HKEY_CURRENT_USER Key.
Expand the Software Key.
Expand the Microsoft Key.

Expand the Windows Key.
Expand the CurrentVersion Key.
Select the RunOnce Key.

Right-click anywhere in the white space of the window.

Hover over New, and then select String Value.

Right-click New Value #1, and then choose Rename.
Type Solitaire, and then press Enter.

Right-click Solitaire, and then choose Modify. 

Type C:\Windows\system32\sol.exe in the Value data field.

Click OK.
Close the Registry Editor window.
Step 11
Log off Windows.

Log on to Windows as an administrator.

What happens when you log in?

Close all open Windows.
Step 12
Choose Start > All Programs. 
Right-click My Computer, and then choose Properties.

Click the Automatic Updates tab. 

Click the Download updates for me, but let me choose when to install them radio button.
Click Apply, and then click OK.
Step 13
Windows checks for updates.

The Updates are ready for your computer balloon appears.

Double-click the shield icon in the system tray.

Click Custom Install (Advanced), and then click Next.

The Choose updates to install window appears.

Click Install. 

The Installing updates balloon appears.
Reboot the computer.
Part 2: Windows XP Hard Drive Maintenance
In this part of the lab, you will examine the results after using Disk Check and Disk Defragmenter on a hard drive.

Recommended Equipment

· A computer running Windows XP Professional
Step 1
Log on to Windows as an administrator.
Start > My Computer > double-click New Volume (G:).
Right-click anywhere in the white space of the folder area for drive G: > Properties > Tools tab > Check Now.

When the Check Disk New Volume (G:) window appears, click Start.
The Disk Check Complete window appears.

How many phases were checked?

Click OK.

Select the Tools tab, click Check Now.

Place a check mark in the check box next to Scan for and attempt recovery of bad sectors > Start.

The Disk Check Complete Window appears.

How many phases were checked?

Click OK.

Select the Tools tab, click Check Now.

Place a check mark in both check boxes and click Start.

An information window opens.

Why will CHKDSK not start?

Note: This message is displayed because a boot partition will be scanned, or a non-boot partition that is going to be scanned is open. 

Click Yes and then OK to close the New Volume (G:) Properties window.
Make sure drive G: stays open.

Note: To force CHKDSK to create a log file, when it scans a non-boot partition with no bad sectors, the non-boot partition drive must be open.

Click Start > Shutdown > Restart.

Step 2
The Checking file system on G: window appears.

How many stages in the scan are there?

What is being verified in each of the stages?

Were any problems found with the volume?

If so what are they?

Step 3
Log on to Windows as an administrator.
Start > Control Panel > Administrative Tools > Event Viewer > in the left pane select Application.
Double-click the top event in the right pane. Click the black down arrow until the disk check event appears.
Which stages are shown as completed?

Close all open windows.

Step 4
Start > My Computer > right-click drive (C:) > Properties > Tools tab > Defragment Now.

The Disk Defragmenter window appears. Notice drive (C:) is selected.
What are the file types and colors, grouped by Disk Defragmenter?

Click Analyze.

When the Analysis is complete for: (C:) window appears, click View Report.

The Analysis Report window opens. Does the volume need defragmenting?

Click on the scroll down bar to view volume information.

Click the Close button.

Drive (C:) has what percentage of free space?

Click the Defragment button.

The defragmenting process begins.

When the Defragmentation is complete for: (C:) window appears click View Report.

Click on the scroll down bar to view volume information.

Volume (C:) has what percentage of free space?

Close all open windows.

Part 3: Managing Processes, and Regional and Language Settings in Windows XP
In this part of the lab, you will examine regional and language settings, and explore how to manage processes in Task Manager.

Recommended Equipment

· A computer running Windows XP Professional
Step 1
Log on to Windows as an administrator.
Press Ctrl-Alt-Delete.
Click the Processes tab. 
Double-click the border around the tabs.

Windows Task Manager is now in compact mode.

Click Image Name.

Click Image Name again.

What effect does this have on the columns?

Click Mem Usage.

What affect does this have on the columns?

Double-click the outside border again for tabs mode.

Step 2
Open a browser. 

Note: Firefox is used in this lab. However, any browser will work. Just substitute your browser name whenever you see the word Firefox.

Return to the Windows Task Manager.
Click Image Name so the list is in alphabetical order and select firefox.exe.

Right-click firefox.exe > Set Priority.

What is the default priority for the browser?

Set the priority to Above Normal.

Click Yes in the Task Manager Warning window.
Step 3
Expand the width of the Windows Task Manager window.
Click View > Select Columns.
Place a check mark next to Base Priority and click OK.

Click Base Pri.

Which image name has a base priority of N/A?

List one image name that has a base priority of Above Normal?

Step 4
Reset Firefox.exe base priority to Normal > Yes.
Click View > Select Columns > uncheck Base Priority > OK.
Close Firefox. 
Is Firefox listed as a process?

Step 5
Click Start > Control Panel > Regional and Language Options.

The Regional and Language Options window appears.
What regional options format is being used?

Click Customize.

What are the tabs that can be customized?

Click Cancel.

Click the dropdown menu in Standards and formats area. Select Belarusian.

Notice the changes to the output in the Samples fields.

Click the dropdown menu in the Standards and formats area.

Return the setting to the original format.

Click Details on the Language tab.

What is the default input language?

Click Cancel > Cancel to close the Regional and Language Options window.

Step 6
Right-click the Taskbar.

Select Toolbars > Language bar to ensure that the Language bar is shown in the Taskbar.
Right-click the Language bar in the Taskbar.

Select Settings.

What is the Default input language?

Part 4: Managing Windows XP System Performance
In this part of the lab, you will manage and monitor Windows XP system performance.
Recommended Equipment

· A computer running Windows XP Professional
Step 1
Log on to Windows as an administrator.
Click Start > Control Panel > Administrative Tools > Computer Management > expand Services and Applications.
Select Services.

Expand the Computer Management window so you see the Help and Support service.

What is the Status of the service?

Right-click the Help and Support service. Select Properties.

The Help and Support Properties (Local Computer) window appears.

Click Stop.

When disabling a service, to free up system resources, it is important to understand how the overall system operation will be affected.

When the Service Control window closes, set the Startup type field to Disabled, and click Apply.

Click Start > Help and Support.
The Help and Support Error window appears.

Why will Help and Support not start?

What must be done to correct the error?

Click OK.

What steps must be followed to start the Help and Support service?
Start the Help and Support service.

Click OK.

Click Start > Help and Support.
Did the Help and Support Center window appear?

Close the Help and Support Center window.

Step 2
Make sure the Computer Management window is open.

Expand Event Viewer. Select System.

Double-click the most recent Error event. Error events are displayed as a white X in a red circle icon.
The Event Properties window appears.

Why was helpsvc not started?

Click the up arrow button.

What has happened to the Help and Support service?

Click the up arrow button.

What has happened to the Help and Support service?

Close all open windows.

Note: NVDA may be preferable for this next section. This is already installed on your virtual machine, or you can ask your instructor for more information.
Step 3
Press Ctrl-Alt-Delete. When the Windows Task Manager window appears, select the Performance tab.
Click Start > Control Panel > Administrative Tools. Open the following tools: Event Viewer and Performance.

Close the Administrative Tools window.

Resize and position all three windows so they can be seen at the same time.

Step 4
Select the Performance window. 

Expand Performance Logs and Alerts. Right-click Counter Logs > New Log Settings.
In the Name field, type Memory Counter.
Click OK.

When the Memory Counter window appears, click Add Counters.

Set the Performance object field to Memory.

Set the Select counters from list field to Available Mbytes. Click Add > Close. 

Change the Interval field to 5.
Select the LogFiles tab.

Set the Log file type field to Text File (Tab delimited).

Click Configure. 
What is the default location for the log files?

Click OK to close the Configure Log Files window.

A folder not found information window appears. Click Yes to create the folder.

Select the Schedule tab.

Keep the default settings and click OK.

In the Performance window, click Counter Logs.

The Memory Counter log icon turns green once it has started.

Step 5
Select the Windows Task Manager window.

What amount of Physical Memory (K) is available?

Hint: This is displayed in the performance tab. You may need to read the entire window for this information
Subtract about 10 MB of the available memory. Example: 1410376 – 10000 = 1400376.

How much available memory is left over?

Step 6
Make sure the Performance window is active.

Right-click Alerts > New Alert Settings.

In the Name field, type Memory Alert, then click OK.
When the Memory Alert window appears, click Add.

Set the Performance object field to Memory.

Set the Select counters from list field to Available Mbytes. Click Add > Close. 

Set the following field values for the General tab:

Alert when the value is: Under
Limit: enter physical memory minus 10MB (see step 5). Example – 1400376

Interval: 5
Units: seconds
Select the Action tab.

Click OK to keep default settings.

In the Performance window, click Alerts.

How can you tell that the Memory Alert has started?

Step 7
To force the computer to use some of the available memory, open and close a browser. Example: Internet Explorer or FireFox.

Right-click the Memory Alert icon > Stop.

Notice the Memory Alert icon has changed to a red color.

Select Counter Logs.

Right-click the Memory Counter icon and select Stop.

How can you tell the Memory Counter has stopped?

Step 8
Make sure the Event Viewer window is active.

Select Application, and double-click the event at the top of the list.

Does the event indicate that the available MBytes has tripped the alert threshold?

If you answered yes to the above question, what was the counter value that tripped the alert event? 

If you answered no, click the down arrow a few times until you find the alert event. If you do not find an alert event ask the instructor for assistance.

Close the Event Properties window, click OK.

Step 9
Click Start > My Computer > double-click drive C: > PerfLogs.
Double-click Memory Counter file.

What does the column on the right show?

Step 10
Close the Memory Counter file, PerfLogs folder, and Windows Task Manager.
In the Event Viewer window click Application > Action > Clear All Events. Click No when you are asked to save the events to a file.

In the Performance window, click Counter Logs > right-click Memory Counter > Delete.
Select Alerts > Memory Alert > right-click Memory Alert > Delete.
Open drive C:. 
Right-click the PerfLogs folder. 

Click Delete > Yes.

Close all open windows.

Note: This portion of the lab is not required for accessibility reasons.
Part 5: Managing Windows XP Remote Access
In this part of the lab, you will remotely connect to a computer, examine device drivers, and provide remote assistance.

Recommended Equipment

· Two computers running Windows XP that are directly connected to each other or through a switch or hub.

· The two computers must be part of the same Workgroup and on the same subnet.

Step 1

Log on to Computer2 as a member of the administrator group. Ask your instructor for the user name.
Click Start > Control Panel > System. 
When the System Properties window appears, select the Remote tab.
In the Remote Desktop area, place a check mark in the box next to Allow users to connect remotely to this computer, and click Apply.

In the Remote Desktop area, click Select Remote Users.

Which user already has remote access?

Since you will use this account to gain remote access, you do not need to add any users, click Cancel.

Close the Control Panel window. 

Move to Computer1.
Step 2
Log on to Computer1 as a member of the administrator group. Ask your instructor for the user name.
Click Start > All Programs > Accessories > Remote Desktop Connection. 
When the Remote Desktop Connection window appears, type Computer2 in the Computer field and click Connect.
In the User name field, type in the account name you used to log on to Computer2. For example: John_Computer2. 

In the Password field, type the password for John_Computer2.

Note: The user account must have a password.

Click OK.

What happened to the desktop of Computer2?

What happened to the desktop of Computer1?

Step 3
On Computer1, right-click the desktop of Computer2 > New > Folder > name the folder Remote Permission.

Right-click the Remote Permission folder > Sharing and Security.
Click the Share this folder radio button. Click Apply.
Click the Security tab. Make sure the user name from Computer1 is listed in Computer2. If it is not, create and add the user name.

Click OK.

Click Start > Disconnect.
When the Disconnect Windows window appears, click Disconnect.
When the Your Remote Desktop session has ended message appears, click OK.
Click Close to exit the Remote Desktop Connection window.

Step 4
Log on to Computer2.
Select the System Properties window.
Click Advanced.

The Remote Assistance Settings window appears.

Make sure there is a check mark in the Remote control checkbox, set the invitation to 1 Hours, and then click OK.

When the System Properties window appears, click Apply.

Step 5
On Computer2, click Start > All Programs > Remote Assistance.

The Help and Support Center window appears.

Click the Invite someone to help you link.

Which methods can you use to contact someone for assistance?

Click the Save invitation as a file (Advanced) link.

The Remote Assistance – Save Invitation window appears.

Type Computer2 in the Enter your name field.

How long will the invitation remain open?

Click Continue.

Make sure there is a check mark in the Require the recipient to use a password checkbox.

Type the password HelpMe and confirm the password HelpMe. Click Save Invitation.

Navigate to the folder Remote Permission.
What is the default file name?

What file type extension does the file have?

Click Save.

When the Remote Assistance window appears, click the View the status of my invitation (1) link.

The View or change your invitation window appears.

Click the Saved radio button. Click Details.

What advice is provided below the Password Protected? heading?

Click Close.

Close the Help and Support Center window.

Step 6
On Computer1, click Start > My Network Place.
Open the folder Remote Permission on Computer2.
Open the file RAInvitation.

When the Remote Assistance window appears, type in the password HelpMe, and click Yes.

Step 7
On Computer2, answer Yes to allow access to the computer.

Read the message in the Connection Status area.

What is the connection status?

In the Message Entry field, type Hi John_ Computer1, my optical drive will not work. > click Send.

Step 8
On Computer1, click the Take Control button in the Remote Assistance main menu.

Step 9
On Computer2, click Yes.

Step 10
Computer1:

What must you do to activate the screen for Computer2?

What key must you press to return control back to Computer2?

Click OK.

Select the System Properties window for Computer2.

Note: If the Computer2 System Properties window is closed, you need to open it before you continue. 

On the Hardware tab, click Device Manager.

Right-click the optical drive with a red X > Enable.

Click the Release Control button in the Remote Assistance main menu.

Click the Disconnect button in Remote Assistance main menu.

Click OK.

Close all open windows.

Step 11
On Computer2, click OK.

Click on the Device Manager window.
Does the optical drive have a red X?

Close the Device Manager window and the Remote Assistance window.

Delete the Remote Permission folder. 

Select the System Properties window.

Remove the check mark from Allow users to connect remotely to this computer > OK.
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